Phone Lines Down
Incident Report for DaySmart
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 17:08 EDT
Update
We are continuing to investigate this issue. More details can be found here https://health.aws.amazon.com/health/status
Posted Sep 28, 2022 - 13:35 EDT
Investigating
We are currently experiencing technical difficulties with our phone system. We are investigating with our third-party phone operating system at this time. Live Chat and Email support continue to be working as intended.
Posted Sep 28, 2022 - 12:58 EDT
This incident affected: Phone Support.